Home » RDBMS Server » Server Utilities » rules missing after import (9.2.0.6)
rules missing after import [message #450152] Mon, 05 April 2010 05:36 Go to next message
ankush_chawla
Messages: 136
Registered: November 2006
Senior Member
We were trying to refresh the QA database from the production export dump.
After import we checked the dba_rules in QA database doesnot show any rule . This seems a reasons for many of the packages get invalidated after import.
I checked the production database that have 16 rules defined under dba_rules tables.
I am not sure abt the syntax for the creation of rules . Is there any way i can take the backup of rules from PROD or some creation of rule script so that i can create similar rules in QA.
Re: rules missing after import [message #496037 is a reply to message #450152] Wed, 23 February 2011 23:18 Go to previous messageGo to next message
manishsri0106
Messages: 6
Registered: February 2011
Location: India
Junior Member

Hi

Please go to the production database and check the invalid objects from dba_objects view and compair it with QA and if invalid objects count in QA is more than production first run utlrp.sql and compair again or compile invalid objects manually .
Re: rules missing after import [message #496039 is a reply to message #450152] Wed, 23 February 2011 23:27 Go to previous message
Michel Cadot
Messages: 67546
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Post your export command.
Check export log.

Regards
Michel

[Updated on: Thu, 24 February 2011 01:18]

Report message to a moderator

Previous Topic: data pump
Next Topic: Import Utility - Default Path Of Import Log File
Goto Forum:
  


Current Time: Sun Nov 29 05:24:28 CST 2020