Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » Report Query Problem (APEX 3.1, Oracle 10g R2, Win 2003 server)
Report Query Problem [message #315169] Sat, 19 April 2008 10:56 Go to next message
Messages: 1
Registered: April 2008
Junior Member
Hi all

I ave installed and configure Apex 3.1 & BI Publisher with Oracle 10g release 2.
Running successfuly.

I have a strange problem with report query.

the query

select * from emp where empno='7486'

works fine when attatched to a page but

select * from emp where empno=:P1_EMPNO

returns no result where :P1_EMPNO is a text item having value '7486'


Re: Report Query Problem [message #315298 is a reply to message #315169] Mon, 21 April 2008 00:38 Go to previous message
Messages: 540
Registered: February 2008
Senior Member

as you have mentioned strange problem, i also occasionaly
had this type of problem.

I tried select * from emp where empno=to_number(:P1_EMPNO);

it worked fine.

I was told that p1_empno would have padded with special
characters. I was not convinced...

any way... try this.. I am offering solution from my
vague memory... try it...


Previous Topic: How to install apex
Next Topic: mod_plsql and j2ee app integration - how to synchronize user session timeout period
Goto Forum:

Current Time: Thu Aug 18 03:11:52 CDT 2022